import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.*[a-záéíóúñ])(?=.*[A-ZÁÉÍÓÚÑ])(?=.*[0-9])\\S{8,16}$";
final String string = "1234567890123456 # Para medir los passwords de abajo\n\n"
+ "MiPasswordBueno1\n"
+ "EstePasswordEsMuyLargo1234\n"
+ "Est4PasswordOK\n"
+ "C0n!Símb0loS\n"
+ "EsC0rt0\n"
+ "sinmayusculas1\n"
+ "SINMINUCULAS1\n"
+ "SiNnUmErOs\n"
+ "F0J1mDmm\n"
+ "·$\"$·\"Aa0\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}