const regex = /[A-Z'\- ]+ (\([A-Z'-]{2}\))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[A-Z\'\\- ]+ (\\([A-Z\'-]{2}\\))', 'gm')
const str = `AFGHANISTAN (AF)
LAND ISLANDS (AX)
ALBANIA (AL)
ALGERIA (DZ)
AMERICAN SAMOA (AS)
ANDORRA (AD)
ANGOLA (AO)`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);