import re
regex = re.compile(r"[A-Z'\- ]+ (\([A-Z'-]{2}\))", flags=re.MULTILINE)
test_str = ("AFGHANISTAN (AF)\n"
"LAND ISLANDS (AX)\n"
"ALBANIA (AL)\n"
"ALGERIA (DZ)\n"
"AMERICAN SAMOA (AS)\n"
"ANDORRA (AD)\n"
"ANGOLA (AO)")
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)