re = /[A-Z'\- ]+ (\([A-Z'-]{2}\))/m
str = 'AFGHANISTAN (AF)
LAND ISLANDS (AX)
ALBANIA (AL)
ALGERIA (DZ)
AMERICAN SAMOA (AS)
ANDORRA (AD)
ANGOLA (AO)'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result