package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\s(<.+)`)
var str = `<span id="3">
HELLO THERE
<span id="5">
Other stuff
<span id="6">
Other Stuff
<span id="7">
Other sutff`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}