import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s(<.+)";
final String string = "<span id=\"3\">\n\n"
+ "HELLO THERE\n"
+ "<span id=\"5\">\n"
+ "Other stuff\n"
+ "<span id=\"6\">\n"
+ "Other Stuff\n"
+ "<span id=\"7\">\n"
+ "Other sutff";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}