#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^\s*(.*?)\s*$"
Local $sString = " " & @CRLF & _
" test string " & @CRLF & _
"" & @CRLF & _
" hello world. "
Local $sSubst = "\1, "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)