use strict;
my $str = '
test string
hello world. ';
my $regex = qr/^\s*(.*?)\s*$/mp;
my $subst = '\\1, ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";