package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\s*(.*?)\s*$`)
var str = `
test string
hello world. `
var substitution = "\1, "
fmt.Println(re.ReplaceAllString(str, substitution))
}