#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(?:#####\s*issue type.*\s+)(?:<!---.*?-->\s+)?([\s\S]*?)(?=\s*(?:#####|$))"
Local $sString = "##### PRIORITY" & @CRLF & _
"- Priority 1" & @CRLF & _
"- Priority 2" & @CRLF & _
"" & @CRLF & _
"##### ISSUE TYPE" & @CRLF & _
"- Problem / Case" & @CRLF & _
"- Requirement" & @CRLF & _
"" & @CRLF & _
"##### ISSUE TYPE" & @CRLF & _
"<!--- comment -->" & @CRLF & _
"- Problem / Case" & @CRLF & _
"- Requirement"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")