re = /(?:#####\s*issue type.*\s+)(?:<!---.*?-->\s+)?([\s\S]*?)(?=\s*(?:#####|$))/i
str = '##### PRIORITY
- Priority 1
- Priority 2
##### ISSUE TYPE
- Problem / Case
- Requirement
##### ISSUE TYPE
<!--- comment -->
- Problem / Case
- Requirement'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end