$re = '/(?:#####\s*issue type.*\s+)(?:<!---.*?-->\s+)?([\s\S]*?)(?=\s*(?:#####|$))/i';
$str = '##### PRIORITY
- Priority 1
- Priority 2
##### ISSUE TYPE
- Problem / Case
- Requirement
##### ISSUE TYPE
<!--- comment -->
- Problem / Case
- Requirement';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);