const regex = new RegExp('(?:#####\\s*issue type.*\\s+)(?:<!---.*?-->\\s+)?([\\s\\S]*?)(?=\\s*(?:#####|$))', 'gi')
const str = `##### PRIORITY
- Priority 1
- Priority 2
##### ISSUE TYPE
- Problem / Case
- Requirement
##### ISSUE TYPE
<!--- comment -->
- Problem / Case
- Requirement`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}