import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"(mini-configurator-wheel__ECLIPSE-CROSS-VI.*?)\"";
final String string = "\"mini-configurator-wheel__SPACE-STAR___2K7QM\":\"_227-b474abbb-chunk__mini-configurator-wheel__SPACE-STAR___2K7QM___2sDZX\",\"mini-configurator-wheel__ECLIPSE-CROSS___Q0oer\":\"_227-b474abbb-chunk__mini-configurator-wheel__ECLIPSE-CROSS___Q0oer___1DY8b\",\"mini-configurator-wheel__OUTLANDER-PHEV-VI___2p68L\":\"_227-b474abbb-chunk__mini-configurator-wheel__OUTLANDER-PHEV-VI___2p68L___F92Lk\",\"mini-configurator-wheel__ECLIPSE-CROSS-VI___1MgIb\":\"_227-b474abbb-chunk__mini-configurator-wheel__ECLIPSE-CROSS-VI___1MgIb___Hue-i\",\"html-editor__noGutters___Ty8gn\":";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}