// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)"(mini-configurator-wheel__ECLIPSE-CROSS-VI.*?)""#).unwrap();
let string = "\"mini-configurator-wheel__SPACE-STAR___2K7QM\":\"_227-b474abbb-chunk__mini-configurator-wheel__SPACE-STAR___2K7QM___2sDZX\",\"mini-configurator-wheel__ECLIPSE-CROSS___Q0oer\":\"_227-b474abbb-chunk__mini-configurator-wheel__ECLIPSE-CROSS___Q0oer___1DY8b\",\"mini-configurator-wheel__OUTLANDER-PHEV-VI___2p68L\":\"_227-b474abbb-chunk__mini-configurator-wheel__OUTLANDER-PHEV-VI___2p68L___F92Lk\",\"mini-configurator-wheel__ECLIPSE-CROSS-VI___1MgIb\":\"_227-b474abbb-chunk__mini-configurator-wheel__ECLIPSE-CROSS-VI___1MgIb___Hue-i\",\"html-editor__noGutters___Ty8gn\":";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}