use strict;
my $str = '"mini-configurator-wheel__SPACE-STAR___2K7QM":"_227-b474abbb-chunk__mini-configurator-wheel__SPACE-STAR___2K7QM___2sDZX","mini-configurator-wheel__ECLIPSE-CROSS___Q0oer":"_227-b474abbb-chunk__mini-configurator-wheel__ECLIPSE-CROSS___Q0oer___1DY8b","mini-configurator-wheel__OUTLANDER-PHEV-VI___2p68L":"_227-b474abbb-chunk__mini-configurator-wheel__OUTLANDER-PHEV-VI___2p68L___F92Lk","mini-configurator-wheel__ECLIPSE-CROSS-VI___1MgIb":"_227-b474abbb-chunk__mini-configurator-wheel__ECLIPSE-CROSS-VI___1MgIb___Hue-i","html-editor__noGutters___Ty8gn":';
my $regex = qr/"(mini-configurator-wheel__ECLIPSE-CROSS-VI.*?)"/mp;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}