const regex = /^[a-zA-Z0-9](?:[a-zA-Z0-9.,'_ -]*[a-zA-Z0-9])?$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[a-zA-Z0-9](?:[a-zA-Z0-9.,\'_ -]*[a-zA-Z0-9])?$', 'mg')
const str = `1
12
1,
,1
,
1,,,,1`;
const subst = `$1\n$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);