re = /^[a-zA-Z0-9](?:[a-zA-Z0-9.,'_ -]*[a-zA-Z0-9])?$/m
str = '1
12
1,
,1
,
1,,,,1'
subst = '$1\\n$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result