use strict;
my $str = '1
12
1,
,1
,
1,,,,1';
my $regex = qr/^[a-zA-Z0-9](?:[a-zA-Z0-9.,'_ -]*[a-zA-Z0-9])?$/mp;
my $subst = '$1\\n$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";