using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?m)^[^\S\r\n]*(\S+(?:[^\S\t\r\n]*\S+)*)\t+(\S+(?:[^\S\t\r\n]*\S+)*)\t+(\S+(?:[^\S\t\r\n]*\S+)*)";
string substitution = @"array($2, ""$1"", ""$3""),";
string input = @" FOO 100 BOR
PAL 350 PIL
KIL 090 KUP
FAS 130 FOO's BAR
FAO 120 Pizza's joy poy
125 My Pot FAO
120 Pizza's joy poy POI";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}