import Foundation
let pattern = #"(?m)^[^\S\r\n]*(\S+(?:[^\S\t\r\n]*\S+)*)\t+(\S+(?:[^\S\t\r\n]*\S+)*)\t+(\S+(?:[^\S\t\r\n]*\S+)*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
FOO 100 BOR
PAL 350 PIL
KIL 090 KUP
FAS 130 FOO's BAR
FAO 120 Pizza's joy poy
125 My Pot FAO
120 Pizza's joy poy POI
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"array($2, "$1", "$3"),"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)