use strict;
my $str = ' FOO 100 BOR
PAL 350 PIL
KIL 090 KUP
FAS 130 FOO\'s BAR
FAO 120 Pizza\'s joy poy
125 My Pot FAO
120 Pizza\'s joy poy POI';
my $regex = qr/(?m)^[^\S\r\n]*(\S+(?:[^\S\t\r\n]*\S+)*)\t+(\S+(?:[^\S\t\r\n]*\S+)*)\t+(\S+(?:[^\S\t\r\n]*\S+)*)/p;
my $subst = 'array($2, "$1", "$3"),';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";