// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[^\S\r\n]*(\S+(?:[^\S\t\r\n]*\S+)*)\t+(\S+(?:[^\S\t\r\n]*\S+)*)\t+(\S+(?:[^\S\t\r\n]*\S+)*)").unwrap();
let string = " FOO 100 BOR
PAL 350 PIL
KIL 090 KUP
FAS 130 FOO's BAR
FAO 120 Pizza's joy poy
125 My Pot FAO
120 Pizza's joy poy POI";
let substitution = "array($2, \"$1\", \"$3\"),";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}