import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"(\\\\[\\s\\S]|[^\"])*\"|'(\\\\[\\s\\S]|[^'])*'|(\\/\\/.*|\\/\\*[\\s\\S]*?\\*\\/)";
final String string = "QUOTES\n"
+ "str = '//\\''; // comment.'test'\n"
+ "str = \"//'\"; // comment.\n"
+ "str = '\\'//\\''; // comment.\n"
+ "str = '\"\\'//\\'\"'; // comment.\n"
+ "str = \"'// \"; // comment.\n\n\n"
+ "COMMENTS\n"
+ "/*'//\\'';// hjkjh.'test'\n"
+ "\"//'\";// hjkjh.\n"
+ "'\\'//\\'';// hjkjh.\n"
+ "\"'// \";// hjkjh.*/ yo; // test.\n\n"
+ "// var i = 'able';";
final String subst = "[$1], [$2], [$3]";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}