$re = '/"(\\\\[\s\S]|[^"])*"|\'(\\\\[\s\S]|[^\'])*\'|(\/\/.*|\/\*[\s\S]*?\*\/)/';
$str = 'QUOTES
str = \'//\\\'\'; // comment.\'test\'
str = "//\'"; // comment.
str = \'\\\'//\\\'\'; // comment.
str = \'"\\\'//\\\'"\'; // comment.
str = "\'// "; // comment.
COMMENTS
/*\'//\\\'\';// hjkjh.\'test\'
"//\'";// hjkjh.
\'\\\'//\\\'\';// hjkjh.
"\'// ";// hjkjh.*/ yo; // test.
// var i = \'able\';';
$subst = "[$1], [$2], [$3]";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;