re = /"(\\[\s\S]|[^"])*"|'(\\[\s\S]|[^'])*'|(\/\/.*|\/\*[\s\S]*?\*\/)/
str = 'QUOTES
str = \'//\\\'\'; // comment.\'test\'
str = "//\'"; // comment.
str = \'\\\'//\\\'\'; // comment.
str = \'"\\\'//\\\'"\'; // comment.
str = "\'// "; // comment.
COMMENTS
/*\'//\\\'\';// hjkjh.\'test\'
"//\'";// hjkjh.
\'\\\'//\\\'\';// hjkjh.
"\'// ";// hjkjh.*/ yo; // test.
// var i = \'able\';'
subst = '[$1], [$2], [$3]'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result