#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "([?!.])\1+"
Local $sString = "Ok!!!" & @CRLF & _
"Really????" & @CRLF & _
"I guess....."
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)