$re = '/([?!.])\1+/';
$str = 'Ok!!!
Really????
I guess.....';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;