use strict;
my $str = 'Ok!!!
Really????
I guess.....';
my $regex = qr/([?!.])\1+/p;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";