import re
regex = re.compile(r"([?!.])\1+")
test_str = ("Ok!!!\n"
"Really????\n"
"I guess.....")
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)