#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(.+\s*=\s*)([^#\r\n]+)"
Local $sString = "foo = "/usr/local/bin" # path string" & @CRLF & _
"eggs = [0, 1, 2, 3, 1]" & @CRLF & _
"spam = True # boolean" & @CRLF & _
"bar = 42" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")