import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.+\\s*=\\s*)([^#\\r\\n]+)";
final String string = "foo = \"/usr/local/bin\" # path string\n"
+ "eggs = [0, 1, 2, 3, 1]\n"
+ "spam = True # boolean\n"
+ "bar = 42\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}