// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(.+\s*=\s*)([^#\r\n]+)").unwrap();
let string = "foo = \"/usr/local/bin\" # path string
eggs = [0, 1, 2, 3, 1]
spam = True # boolean
bar = 42
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}