import re
regex = re.compile(r"(.+\s*=\s*)([^#\r\n]+)", flags=re.MULTILINE)
test_str = ("foo = \"/usr/local/bin\" # path string\n"
"eggs = [0, 1, 2, 3, 1]\n"
"spam = True # boolean\n"
"bar = 42\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")