using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<br>\s?-\s?(.*?)";
string input = @"any text - any text any text any text any text any text
<br><br>- any text any text<br>- any text 1 2 3 | \ ,<br><br>
<br>any text";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}