use strict;
my $str = 'any text - any text any text any text any text any text
<br><br>- any text any text<br>- any text 1 2 3 | \\ ,<br><br>
<br>any text';
my $regex = qr/<br>\s?-\s?(.*?)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}