import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<br>\\s?-\\s?(.*?)";
final String string = "any text - any text any text any text any text any text \n\n"
+ "<br><br>- any text any text<br>- any text 1 2 3 | \\ ,<br><br>\n"
+ "<br>any text";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}