import re
regex = re.compile(r"^[^`~!@#$%^&*()_+={}\[\]|\\:;“’<,>.?๐฿]*$", flags=re.MULTILINE)
test_str = ("asdad\n"
"sdf@323\n"
"asdasdadq@3333\n"
"[][]asd\n"
"dddddd[\n"
"127 elmer road ??<>()")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")