re = /^[^`~!@#$%^&*()_+={}\[\]|\\:;“’<,>.?๐฿]*$/m
str = 'asdad
sdf@323
asdasdadq@3333
[][]asd
dddddd[
127 elmer road ??<>()'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end