using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(Merge\sbranch\s\'|\#\sRebase\s|This\sreverts\scommit\s)";
string input = @"Merge branch 'testing' into master
# Rebase commit 9f3bc7b
This reverts commit 28da9f6
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}