import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(Merge\\sbranch\\s\\'|\\#\\sRebase\\s|This\\sreverts\\scommit\\s)";
final String string = "Merge branch 'testing' into master\n"
+ "# Rebase commit 9f3bc7b\n"
+ "This reverts commit 28da9f6\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}