import re
regex = re.compile(r"(Merge\sbranch\s\'|\#\sRebase\s|This\sreverts\scommit\s)", flags=re.MULTILINE)
test_str = ("Merge branch 'testing' into master\n"
"# Rebase commit 9f3bc7b\n"
"This reverts commit 28da9f6\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")