$re = '/(Merge\sbranch\s\'|\#\sRebase\s|This\sreverts\scommit\s)/m';
$str = 'Merge branch \'testing\' into master
# Rebase commit 9f3bc7b
This reverts commit 28da9f6
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);