#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((?<leapFeb>(([13579]{1}[26]{1})|([02468]{1}[048]{1}))02(([0]{1}[1-9]{1})|([12]{1}[0-9]{1})))|(?<nonLeapYear>(?<anyYear>[0-9]{2})(?<nonLeapYearMonths>(?<all31DayMonths>([0]{1}[13579]{1}|[1]{1}[02]{1})(([0]{1}[1-9]{1})|([12]{1}[0-9]{1})|[3]{1}[01]{1}))|(?<all30DayMonths>([0]{1}[468]{1}|[1]{1}[1]{1})(([0]{1}[1-9]{1})|([12]{1}[0-9]{1})|[3]{1}[0]{1}))|(?<nonLeapYearFeb>02(([0]{1}[1-9]{1})|([1]{1}[0-9]{1})|([2]{1}[0-8]{1}))))))$"
Local $sString = "850228" & @CRLF & _
"850229" & @CRLF & _
"840229" & @CRLF & _
"930822" & @CRLF & _
"930922"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")