$re = '/^((?<leapFeb>(([13579]{1}[26]{1})|([02468]{1}[048]{1}))02(([0]{1}[1-9]{1})|([12]{1}[0-9]{1})))|(?<nonLeapYear>(?<anyYear>[0-9]{2})(?<nonLeapYearMonths>(?<all31DayMonths>([0]{1}[13579]{1}|[1]{1}[02]{1})(([0]{1}[1-9]{1})|([12]{1}[0-9]{1})|[3]{1}[01]{1}))|(?<all30DayMonths>([0]{1}[468]{1}|[1]{1}[1]{1})(([0]{1}[1-9]{1})|([12]{1}[0-9]{1})|[3]{1}[0]{1}))|(?<nonLeapYearFeb>02(([0]{1}[1-9]{1})|([1]{1}[0-9]{1})|([2]{1}[0-8]{1}))))))$/m';
$str = '850228
850229
840229
930822
930922';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);