use strict;
my $str = '850228
850229
840229
930822
930922';
my $regex = qr/^((?<leapFeb>(([13579]{1}[26]{1})|([02468]{1}[048]{1}))02(([0]{1}[1-9]{1})|([12]{1}[0-9]{1})))|(?<nonLeapYear>(?<anyYear>[0-9]{2})(?<nonLeapYearMonths>(?<all31DayMonths>([0]{1}[13579]{1}|[1]{1}[02]{1})(([0]{1}[1-9]{1})|([12]{1}[0-9]{1})|[3]{1}[01]{1}))|(?<all30DayMonths>([0]{1}[468]{1}|[1]{1}[1]{1})(([0]{1}[1-9]{1})|([12]{1}[0-9]{1})|[3]{1}[0]{1}))|(?<nonLeapYearFeb>02(([0]{1}[1-9]{1})|([1]{1}[0-9]{1})|([2]{1}[0-8]{1}))))))$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}