# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:\G(?!^)|\()[^()\s]*\K\s++(?=[^()]*\))/_/gm;t' <<< "(word1 word2 word3) (... ... .. )
(word1 word2 word3 ... ... .. )"