use strict;
my $str = '(word1 word2 word3) (... ... .. )
(word1 word2 word3 ... ... .. )';
my $regex = qr/(?:\G(?!^)|\()[^()\s]*\K\s++(?=[^()]*\))/mp;
my $subst = '_';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";