$re = '/(?:\G(?!^)|\()[^()\s]*\K\s++(?=[^()]*\))/m';
$str = '(word1 word2 word3) (... ... .. )
(word1 word2 word3 ... ... .. )';
$subst = "_";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;