re = /(?:\G(?!^)|\()[^()\s]*\K\s++(?=[^()]*\))/m
str = '(word1 word2 word3) (... ... .. )
(word1 word2 word3 ... ... .. )'
subst = '_'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result